SR20 Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
113 Posts
Discussion Starter · #1 ·
Prior to this my car was pulling to the right all the time. Also, I was getting really bad shuddering on braking and I thought maybe I warped the rotors again. Today, I thought why not switch the front rotors (left side to right side and vice versa) and see what happens. Well now the car goes left on any acceleration then right when I take my foot off the gas pedal. While cruising and braking the car stays straight and shudder free respectively. BTW, I know for a fact that my passenger side lower control arm is shot (bad bushings due to previous power steering leak). Is this causing my troubles? thanks guys.
 
G

·
I had the turn right problem, was also the rt. lower control arm, slightly bent and bad bushings.(curb) But the left turn thing? VooDoo... I also have the shudder during brakeing and new rotors didn't help.
 

·
Registered
Joined
·
513 Posts
Is this a common problem? My car pulls kinda hard to the right when I gun it.

------------------
Kevin
93 Ruby Pearl Classic
w/ advanced timing & Stillen POP
 

·
Registered
Joined
·
113 Posts
Discussion Starter · #5 ·
If it were torque steer then it makes me drive like I'm drunk. I have to laugh at myself, I'm constantly going left, right, left, right. Actually it's also pissing me off. This week I'm going to bite the bullet and attempt to remove/replace the right side lower control arm.
 
G

·
I had the same wandering problem. Mine was a bent contol arm and a bent swaybar brace.

------------------
1999 SE Limited: JWT POP, NGK Wires, OBX Muffler 2.25" exhaust, Hotshot header, Eibach Sportlines, KYB AGX, 17 deg. timing
 

·
Registered
Joined
·
113 Posts
Discussion Starter · #7 ·
Hey I just remembered something else! 2 months ago I replaced the bushings on the passenger side sway bar end links using Energy Suspension bushings. I forgot to go back and do the driver side bushings. Could this be the source of my constant "torque steer"?

Anyway, I will be replacing those last bushings tomorrow.
 

·
Registered
Joined
·
113 Posts
Discussion Starter · #8 ·
Victory! I installed the driver side sway bar end link bushings today. The weird pulling on accel is 90% gone. I'm sure the last 10% is due to a broken passenger side end link. It's not disconnected in any way but the little ball joint is partially out of its socket.

Cool, I'm close to getting back a smooth ride again. woohoo!
 
1 - 8 of 8 Posts
Top