SR20 Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1,160 Posts
Discussion Starter · #1 ·
Hey guys, you know how my car was making all those weird noises at the track? well everything is fixed! me and my brother got the bolts for the crossmember in today, tapped 2 of the holes, put the bolts in and NO MORE NOISES! no more clunking, and the power steering pulley isnt scraping!! We are gonna have to get together again in a couple weeks and go to Bithlo again.... :cool:
 

·
Premium Member
Joined
·
11,741 Posts
Is this Thomas, or Kevin...I know both of you guys have broken SE-Rs. BTW, how is the white one, got an engine yet?
 

·
Banned
Joined
·
2,587 Posts
Fast91SER said:
Is this Thomas, or Kevin...I know both of you guys have broken SE-Rs. BTW, how is the white one, got an engine yet?

Thats Thomas, and I dont think that the white one got a new engine yet.
 

·
Banned
Joined
·
2,587 Posts
BTW, glad to hear you got it running! Serb, i also have to send you new pics sometime, I have diff colored wheels now, and more mods. :)
 

·
Registered
Joined
·
229 Posts
Alright tommy, Les go. Sucka, battle of the SRs egg vs. classic. hmmmm
You'll prolly win, but crazy stuff does happen.
Actually, take that you'll probly win crap away. Man, what was I thinking, of course I'm gunna blow you away! :D :D :D :D :D
 

·
Registered
Joined
·
1,160 Posts
Discussion Starter · #7 ·
yeah its me thomas, my brother hasnt got his engine yet, im gonna lend him some money so he can get it faster. but my car is running good, its just that power steering line i broke when i putting my engine in, i think its giving me problems. because when i turn, it has a little delay, like the steering will just catch all of a sudden, and like the steering wheel will stay turned to the left but i will be going straight? i dont know whats wrong with that...but besides that its doing great...jared when do u wanna race?
 
1 - 8 of 8 Posts
Top