SR20 Forum banner

1 - 15 of 15 Posts

·
Wiggatastic!
Joined
·
1,043 Posts
Discussion Starter #1


If you can't read it, the numbers are in my sig. All mods that are in my sig except for the nitrous and G20 ecu. I also thought it was wierd that it hit fuel cut at 6900 rpms and not 7150 or whatever its supposed to be..

I wasn't sure if this was good or not, but I did think my torque number were pretty high compared to some other dyno's I have seen.

some more pics from the dyno:



 

·
Wiggatastic!
Joined
·
1,043 Posts
Discussion Starter #3
Monsoon said:
That car needs a wax job and air in that tire. I hate you, Marcass. ;)

Good numbers, though.

Shut up Ryan, you only wish you had an sr20 to dyno... ;)
 

·
Wiggatastic!
Joined
·
1,043 Posts
Discussion Starter #5
JimR said:
What kind of gains from the headers?

I rolled there in probably the same conditions (cold) with similar mods other than the exhaust.

This was my first dyno, so I don't really know the gains on just the header. I don't really think the muffler delete did anything for me, if anything maybe like 1 hp. I just know its really loud and obnoxious, I love it! :D

~ Marcus
 

·
Seeing red
Joined
·
2,084 Posts
Your dyno plot looks a lot like mine (same engine, they should ;)).

I make peak power later and torque falls a little more sharply up top. I guess that can be chalked up to the highport/lowport difference and the header.

I need to install some headers.
 

·
it's an se-l..not an se-R
Joined
·
710 Posts
you need some cams.
 

·
Wiggatastic!
Joined
·
1,043 Posts
Discussion Starter #9
REDSENTRASE-L said:
you need some cams.
Thats the damn truth....I actually just went the cheap way and picked up a highport intake cam tonight. ;)
 

·
Wiggatastic!
Joined
·
1,043 Posts
Discussion Starter #14
Storm88000 said:
Although your 1/4 mile time is right on as mine was. I ran a 15.4 @ 88 with just a Hotshot Header and Hotshot CAI.
Did you ever dyno that set-up?
 
1 - 15 of 15 Posts
Top