SR20 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
222 Posts
Discussion Starter #1
Ugh. To fix this, do I need to take the whole cluster out, or can I just take the bottom part of the dash (whats under the steering wheel) and get to it from underneath? I've heard a lot about people breaking the speedo because they pulled the pin off while trying to take the needles off the instruments, and if I can, I'd like to avoid that. Can somebody give me some advice on the job? TIA

-jason
 

·
Stuck on an island
Joined
·
1,284 Posts
have you checked your speedo cable ? maybe it snaped

------------------

92 NX2000, kyb agx, intrax springs, jwt pop,
3a Racing muffler with bonzi tip,
17 " mille miglia mm 112, Yokohama avid h4
ACT clutch on order
 

·
Team Tool
Joined
·
2,514 Posts
What year is it, the 200sx's have an electronic speedo.

------------------
Place Racing CAI,JWT S4 cams and JWT ECU with S4 program, hotshot gen3 header, greddy SP exhaust, KYB AGX's and Ground Controls, Konig Traffiks with Nitto NT555's
 

·
VVL - Very Very Loud™
Joined
·
11,741 Posts
It may not be obvious if it snapped or not, it could be just the metal part of the cable thats covered in the plastic.
you could look down and see if the cable popped out of the tranny. or if you can, try to stick your hand up behind the dash, and see if its disconneted from the instrument cluster.
if its still connected in the tranny, and the instrument cluster, then you have a busted cable, and need a new one. its about $35 at the dealer.

------------------
Serban Gavrilescu
91 Black Metallic SE-R
http://www.geocities.com/serban91r
 

·
Registered
Joined
·
222 Posts
Discussion Starter #5
Its a '91. Is there a way to check and see if it snapped without having to take my dash apart?

-jason
 
1 - 5 of 5 Posts
Top