SR20 Forum banner

1 - 10 of 10 Posts

·
Banned
Joined
·
2,587 Posts
Discussion Starter · #1 ·
Ok, we got my driver side axle back in, and everything together. I go for a ride,p and abouve about say 10 mph or so I hear this bad noise from my driver side axle kinda sounds like schk schk schk schk sck, and it gets faster the faster i go. brakes dont affect the noise, clutch engaged or not, it makes the noise while rolling. I drove to work and back home now for luch, and its not loud anymore. It sounds kinda like braks rubbing metal vs metal, but very fast. Any ideas? TIA!
 

·
Mr.200SX @ the dash
Joined
·
1,679 Posts
Have you checked to see if the metal guard that his behind the brake disc its rubbing agaisnt the disk itself? if so just push it back a little bit you might have bend it by accident it happened to me when I did my axles as well.
 

·
Banned
Joined
·
2,587 Posts
Discussion Starter · #3 ·
NissanSer54 said:
Have you checked to see if the metal guard that his behind the brake disc its rubbing agaisnt the disk itself? if so just push it back a little bit you might have bend it by accident it happened to me when I did my axles as well.


Good idea, I never thought of that. i'll ahve to do it when I get home tonight, Im about to leave for work now. Thanks man! AAny other ideas anyone?? TIA!
 

·
Registered
Joined
·
899 Posts
i think nissanser54 nailed i would check the all the brakes pads as well i had a similar problem with my 2000 but i just needed new brake pads
 

·
Banned
Joined
·
2,587 Posts
Discussion Starter · #5 ·
SE4U2NV said:
i think nissanser54 nailed i would check the all the brakes pads as well i had a similar problem with my 2000 but i just needed new brake pads


DEFINATELY not the brake system, it doesnt change at all when I press the brakes. Plus, my pads are only a couple months old.Keep the ideas rolling everyone! Thanks!
 

·
Anti-Search Nazi
Joined
·
1,194 Posts
I know this sounds stupid, but make sure your lugnuts are tourqed down. I had the same thing happen when I installed my driver side axle, and the same sound you are talking about started, I immediately pulled over, and jacked the car up and when I put the lug wrench of a lugnut it was super loose, so I kicked myself in the ass for getting all exited and not tourqing down the lugnuts, lol. :D
 

·
Banned
Joined
·
2,587 Posts
Discussion Starter · #10 ·
SR20steve said:
I know this sounds stupid, but make sure your lugnuts are tourqed down. I had the same thing happen when I installed my driver side axle, and the same sound you are talking about started, I immediately pulled over, and jacked the car up and when I put the lug wrench of a lugnut it was super loose, so I kicked myself in the ass for getting all exited and not tourqing down the lugnuts, lol. :D

My lug nuts are definately tight, as is my axle nut. I will try to tighten them both again though. I havent had time to check and see if the splash guard is rubbing or not. Now I can hears, sometimes when I rev my engine I hear something is rattling or vibrating/rubbing around the driver side axle. Anyone else? If I'm not too tired I will try to check these things already mentioned. Thanks guys!
 
1 - 10 of 10 Posts
Top