SR20 Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello all. I am having dramas with my girls beautiful 200sx. It was in storage for a year or two and since we have got it back on the road it seems to be drinking fuel like nothing else as well as the revs hunting to sometimes stalling.

She has had some bolton work such as HKS silent catback,FCON pro V3.0,HKS pod filter,GFB BOV,HKS injectors,custom intercooler.

Now im looking at doing some engine internals and upgrade of turbo and headers but need to get to the bottom of this problem first.little help?:(........
 

·
Registered
Joined
·
1,311 Posts
check for air leaks... sounds like unmetered air going past the maf, might wanna clean the maf too....

How much gas have you ran through it? Some times you run some clean gas through a car that's been sitting a long time and it'll start running right again.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
hey mate,
It has had at least 3 tanks through it of premium.
i was just investigating further and decided to take the fcon pro ecu out and go with original ecu. i went to search for the maf sensor to measure(i have a workshop manual with all the voltages) and found there isnt one. It seems the fcon pro has being do the job of the maf sensor. Could that be right?
Since putting the original ecu in,it idles great(and there is no dark smoke from exhaust unlike before) however when you hit the gas the engine flutters over about 2000 rpm,more than likely because no Maf. There is a plug cable tied near the pod that looks the same as the maf sensor plug in the manual.

Dont know what to do from here though. It is pointing towards the tune on the fcon pro but without the sensor im screwed yeah?
 
1 - 3 of 3 Posts
Top