SR20 Forum banner
1 - 8 of 8 Posts

·
Premium Member
Joined
·
4,241 Posts
Discussion Starter · #1 ·
Not getting any action in the Members' Rides forum... Cut & Paste!

Before:



After:







Amazing what a day and a half in Ben's garage will do...
 

·
Registered
Joined
·
1,147 Posts
not too shabby. it'd look really good if you cleaned up the black hoses and took some metal polish to some of the lines. but being in OH, the snow would probably muck it up. :D i like the black and red theme, though. maybe you could paint the stb ends red?
 

·
Registered
Joined
·
497 Posts
Huge difference Stine, it looks a lot better bro. I removed my MAF, removed the sensor, then hit it with a steel brush. Then painted it with chrome paint. Looks damn good on my Aztec Red, but would look even better on your black car. Nothing looks better on a black car than CHROME buddy. Plus I hit the dist., brackets and other stuff too. Damn I wished I had a digital camera!

Late
 

·
Premium Member
Joined
·
4,241 Posts
Discussion Starter · #6 ·
The plug wires haven't fallen out yet...

Any recommendations for a good set that will stay in for sure, that won't break my wallet?
 

·
pwnd
Joined
·
3,455 Posts
A set of stock OEM wires. Buy them once for atleat 60,000 miles and you get your money's worth. Those aerospeed suck ass totaly. after dealing with 2 different sets this weekend I declair that. I dont care how cheap they are or how big they are, the first time you end up on the side of the road come talk. John's car wouldnt even turn over with the set he drove in with. And those you have i would be worried as hell it would pop out or arching like mad down in the plug hole since its not a tight fit. They got the distrubutre side good, why couldnt they make the plug end fit that tight
 
1 - 8 of 8 Posts
Top