SR20 Forum banner

61 - 80 of 100 Posts

·
Registered
Joined
·
19 Posts
Excellent thread. Can anyone in here advise me on where i can get parts to purchase for this W10 Avenir Sr20det engine FWD. Currently im looking for the TPS Sensor and the Knock Sensor. Much thanks.
 

·
Registered
Joined
·
3,030 Posts
Knock sensor can be swapped from your current DE or a new one can be purchased from the dealer, or ebay.

TPS should be the same as the USDM one too, so you can get away without swapping it.
 

·
CAR SLÜT
Joined
·
1,622 Posts
Wiring loom pinout?

Just use the DE wiring loom and plug the W10 ECU in :D
 

·
adrenaline junky
Joined
·
161 Posts
de out/w11 in- sensors?

de- knock, iacv, coolant sensors, need to be tranfered over to w11? anything else? sorry dont mean to interupt thread..thanks:confused:
 

·
CAR SLÜT
Joined
·
1,622 Posts
Can use the DET knock, it plugs in to DE loom.
IACV just needs wiring plug cut and swapped to suit DE loom
Only the single wire DE coolant sensor gets swapped over.
DE TPS can be swapped over as well.
 

·
Registered
Joined
·
256 Posts
Are the Avenir motors Highport or Lowports? Sorry for the newb question.
 

·
Registered
Joined
·
1 Posts
Hi, I have a W11 GT4-S and the starter motor just died. We can't seem to access it from taking off the plenum or taking off the transfer case, does anyone know away to get at it without taking the whole motor out?

Cheers
 

·
24/7 Baller!
Joined
·
306 Posts
Try it from below, should be much easier. Thats how I did it with my low port DE and it should be much easier on a highport due to a bracket that was only on low ports.
 

·
CAR SLÜT
Joined
·
1,622 Posts
W11 is AWD from the factory, the transfer case will be in the way right?

Should be able to unbolt it if the transfer case is out of the way. The two bolts on the gearbox side of the motor holding the starter in should allow you to slide it back and between the exhaust and the right hand side lower control arm :)
 

·
Registered
Joined
·
16 Posts
Excuse me for the question, but i think that you guys can help it out with this problem.

I have a B13 SE-R with SR20DET Avennir Engine (Stock Internals, Stock Turbo), SR20DE MAF, SR20DE ECU, and Greddy E-Manage Blue.

Actually i have a W10 SR20DET ECU (A/T), and i want to installed in my car with a Z32 MAF.

Few days ago, i probe to plug the W10 ECU, with a DET MAF (Not sure if it was Bluebird or Avennir W10), and the car stars great, the minimum was awesome (not up and down idle), and all look to be great before 5000 rpm.

At this Rev, the car just don´t want to pass away. I scan the DET ECU and throws 2 Codes: Ignition Signal and Knock Sensor (This last one is old, and i know how to try to solve it).

Some guys, said that i have to put the W10 MAF for a W10 ECU, ando some guys said that the Avennir ECU is just too complicate for work with other MAFs.

I know that, with the E Manage Blue, i can change automatically the type of MAF (Nissan hot wire sensor) than i can used, but with some changes when i was running the W10 ECU, the car doesn´t want to rev after 5k.

The problem is, when i back to basics (DE ECU, DE MAF) the RPMs goes to Red Line normally (7600 rpm).

I want to know, if theres some difference between bluebird and W10 ECU that i have to consider or some wire that i have to ground it or something to make my DET ECU works fine.

I have tried to search the W10 Pinout ECU, and i can´t find it. I just have de Bluebird ECU Pinout, SE-R obd1, S13 obd1, etc.

Any help, i will appreciate it.

Thank you guys.
 

·
CAR SLÜT
Joined
·
1,622 Posts
W10 ECU is the same as the U13 ECU, just an updated fuel and timing map. The A/T ECU is fine for M/T usage as well, been done plenty of times before ;)

All S13 SR20DE(not DET), B13 SR20DE, U13 DET and W10 DET all use the same ECU plug wiring pin out.

What MAF part number did you use? Did it have 54C00 on the end?
 

·
Registered
Joined
·
16 Posts
W10 ECU is the same as the U13 ECU, just an updated fuel and timing map. The A/T ECU is fine for M/T usage as well, been done plenty of times before ;)

All S13 SR20DE(not DET), B13 SR20DE, U13 DET and W10 DET all use the same ECU plug wiring pin out.

What MAF part number did you use? Did it have 54C00 on the end?
Thanks for the answer. Do you have the link or web address of the W10 pin out?. I just want to be sure for no doubts. I just search for hours and hours with no answers for W10 ECU pinout. May be if i will understand japanese, it will be easier, lol

I have a Friend that is runnig the same Engine that i have, but with a Bluebird ECU and DET MAF (the same one that i probe in my car, im not sure if is avennir or bluebird) and he don`t have problems at all. The car Starts normally, Runs great and Revs to Redline.

I will get the MAF number tonight and i will post it. My friend has the DET MAF.

Any idea, of what is happening in my car for run untill 5000 rpm?.

I`m so much confussed, because when i return to my normal set-up (DE ECU, DE MAF), the car runs normally. :(
 
61 - 80 of 100 Posts
Top