SR20 Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
2,315 Posts
Discussion Starter · #1 ·
So I've got a ghettoized T25 setup in my NX, I'm still waiting for all the toys before I can REALLY drive it but I was able to log a few miles the past few days...
My question is, the now that my real IC piping has arrived I removed my ghetto setup, there is a lot of oil in the pipe as well as a little bit on the intake side of the turbo.

This is an Aviener DET I got second hand from a guy. It has a pretty large aftermarket oil line connected to the stock location on the block. I'm assuming/hoping that all I need to do is get a restrictor - can anyone confirm/deny? I've never seen/heard of oil on the intake side of the turbo.

Thanks all

Chris
 

·
Tired!
Joined
·
10,149 Posts
Yeah, I am heading home this weekend and can send you a restrictor chris, but it is tapped for 1/8" NPT in/out.

Brent
 

·
Registered
Joined
·
2,315 Posts
Discussion Starter · #7 ·
Brent I'll be in novi next tuesday-thursday - maybe you can just mail it to me there so I'll get it in like a day and I'll bring it back with me... I THINK I may have found the problem...
There are two large hoses behind the distributor on the valve cover - one goes to the front catch can, the other my stock intake hose, from what I've read, the one that goes to the stock intake hose SHOULD be connected between the MAF and the turbo, mine is on the stock hose which is still in the stock location - so I'm thinking I'm pressurizing the engine when in boost and possibly forcing oil into the turbo???? I'm going to disconnect it and re connect my K&N filterette to it and see what happens..

Chris
 

·
Tired!
Joined
·
10,149 Posts
Correct, that should be on the intake pipe to the turbo.

I can mail it to novi, just give me an address. ALso, can you ship that box to me i left at your house when I was in KY?

Brent
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top