SR20 Forum banner
1 - 9 of 9 Posts
G

·
Discussion Starter · #1 ·
This is my first post on this forum. I am a regular to the Toyota MR2 forum, as that is my main car, but on another note, I am getting back my SE-R tomorrow, from a half-ass repo, and I want to get something fixed up, so I am going to copy/paste something here (what I wrote on the MR2 forum, which lead me here), and I hope maybe someone had a similar experience and can help me out.

;-)

Well, it kinda got repo-ed and stuff, but anyways, it kinda wasn't repo-ed, it is a long story, so lets get to the point.

Before it got half-ass-repo-ed, I was having some minor probs, and now that I am getting it back, I want to know what to look for...

Ok...
I got the J-spec engine in it, and it is sweet, and rather quick (BTW, it is a 1991 Nissan Sentra Se-R).

Probs...No speedo, no Odometer working (Don't really care either).

Main prob...
It will run fine for like 2 days...
Then, all of a sudden, even on a full tank of gas, it will just shut off while I am driving. Full throttle does nothing, it feels like there is no gas going there. So I can be doing 50 MPH, and it will just not GO anymore. I can kickstart and very seldom, it will start right up and continue running, but most of the time, it starts up and shuts off again.
Then, when I go to restart it, it will CRANK and CRANK, and CRANK, until I totally kill the battery. Sounds healthy, but it just doesn't seem to get any fuel, even if I hold down the gas peddle while trying to start.

So anyways, then I leave for about 1 hour, and come back, and it will start right up, and we are back to square one.

Any ideas what to look for ? I need this as my daily driver for awhile, so hopefully this is easy.
 
G

·
Discussion Starter · #5 ·
Wow, I hope it is that easy!

Even a fuel pump recall doesn't really bother me, I wouldn't mind if I had to replace that.
 

·
Registered
Joined
·
858 Posts
many years ago i had something similar and it turned out to be the engine temp sensor. also a friend of mine had an od chevy that when the coil would get hot ,the car would turn off so he would wait an hour and presto started up so we bought an accel coil for 20 bucks at the time and no more problems . you should try an ecu self diagnosis. the codes should tell you exactly what's wrong. if you don't know how to do this, get a chilton/hayes book at a big auto parts store and it tells you in there.takes about ten minutes to do. mechancs charge you 50$ out here for this diagnosis.

------------------
91 SE-R,10:1 comp.pistons,balanced &blueprint rebuild.comp.4angle valve job,extrude honed heads/intake manifold,No emissions.crap,RC TB/MAF,nismo cams,UR pulleys,stillen4-1 ceram.header,nismo/centerforce dual fric.clutch,PR CAI,2 1/2 test pipe,mandrel 2 1/4 superturbo ex.,and a whole bunch of other goodies! boost is in the works ,hell yeah 3:16!
 
G

·
Discussion Starter · #7 ·
Thanks for the info.

Unfortunately, I can't do the diagnosis myself now, as I dropped the car off today at the shop.

The inspection and registration have run out, so I told him that I would re-register it, and in the meantime, find everything that is wrong with the car, and go ahead and fix it up.

I will let you know the results.

------------------
www.mr2pa.com - Home of my 1991 MR2 Turbo - "The Angel"
 

·
Registered
Joined
·
54 Posts
<font face="Verdana, Arial" size="2">Originally posted by SoAngel:
Wow, I hope it is that easy!

Even a fuel pump recall doesn't really bother me, I wouldn't mind if I had to replace that.
</font>
My fuel pump went out at 65K miles... Bought it in 1991 and was never notified of the fuel pump recall. I was notified of a seatbelt recall however...I was angry at Nissan over the non-notification.
 
G

·
Discussion Starter · #9 ·
Hmm I have a 1991 sentra SE-R.

What was the recall for? Even though she's gone over 150K miles (yeah yeah the wife and I love to drive), we brought her "slightly" used at 59K miles, so I doubt the pump got replaced unless the previous owner had it replaced.. (she did work for the nissan dealership I brought my red baby from)

I'm asking cuz even now my car doesnt want to start, but keeping the gas pedal to the metal and having the starter cranking until the engine fires to life, she cranks slowly, then faster and faster..

Some of my friends thinks it's the fuel pump/filter, other thinks the wasnt rnough fuel being combusted..
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top