SR20 Forum banner
1 - 1 of 1 Posts

1 Posts
Discussion Starter · #1 ·
Ok. I’m new here and I hate to start by asking a question, but here we are and I can’t get this engine to run right.

basic info
1: S14 SR20DE
2: stock ecu (6F500), stainless headers, Tomei Poncam (11.2mm lift, 260° intake/exhaust), exedy lightweight flywheel and stage 1 clutch (whatever that means) from a DET setup. New TPS (original tests fine), new knock sensor, and new (correct MAF).
3: software - data scan along with PLMS consult cable (no piggyback).
4: tps adjusted to .44v at operating temp, 19° timing advance (running 93 octane), no vacuum leaks. All set in timing mode. I have a timing light, fast idle thermoswitch adjusted per FSM, and throttle body clean and adjusted correctly.


was driving after setting idle speed and timing. At time vehicle idle would dip at stops, so I decided to go through everything make sure all was right.

decided to calibrate thermo switch, and double check TPS. at this point, data scan was showing “TPS CLOSED - ON” at the .44v.

BUT… somehow the ecu then decided to go skynet on me and change the “TPS CLOSED” parameter to .10v. Not the sensor, not anything mechanical. Just the ECU changing the parameter.

i will add, if I manually put the TPS at .10v set everything in timing mode, then close out timing mode, this idles and run perfect (right around 750-800rpm), but at WOT I only see about 3.2v. It should be at 4.1v-4.2v, correct?

if I leave the TPS at the correct .45v, the idle will continue climbing and getting warmer. I stopped it at 1700rpm

I can’t seem to figure out how to fix this.

things I’ve tried:
cycling the key
Disconnecting the battery overnight
Tried to start, stop, wait ten seconds, restart (several times)
Cleared learn
And keep hoping ECU will show me the parameter in the .45v range. NO LUCK.

I can only find threads about setting tps, but nothing on how to get this ECU back to its default setting.

thoughts: would the reset screw on the ECU solve this? Is there ANYTHING in data scan that could help?
1 - 1 of 1 Posts