SR20 Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter · #1 ·
Ok, it happened again. I was driving last night and when I pulled into a parking lot and stopped, my '93 auto-tranny SE-R died. For the past five years whenever I start my car the idle would waver and go up to 1200rpm, come back down to 600, then up, then down, until it finally settles at about 1000 after a few seconds. Then when I put it into drive or reverse, the idle would dip like it was about to die and I'd have to catch it by giving it a little gas and just driving away (or it probably will die). I've done the MAF re-ground (though I didn't measure it so I'm not sure if I've done it right) - what can cause this? Anybody? I've just had the fuel filter replaced and changed all major fluids. Help? Thanks.
 

·
www.motorists.org
Joined
·
3,047 Posts
Your car has done this idle song and dance for five years? And now it dies every once in a while? What other regular maintenance have you done?

------------------
Ben98SentraSE
98 Sentra SE TURBO
 

·
Stuck on an island
Joined
·
1,284 Posts
Have you ever cleaned your EGR ? If not you should give that a try, it help my NX when I did it.
 

·
pwnd
Joined
·
3,455 Posts
It is probaly as simple as the idle is set wrong. Because the auto drag to the engine it pulls the idle way down. My idle was a bit off and it would really chug at a stop light, felt like the engine was going to fall out...and I need mounts too. But check your timing...make sure its atleast 15* btdc and then set your idle. Its alot more work to do that on an automatic tho.
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #5 ·
Doh! You mean setting the timing and idle is harder on an automatic than a manual? I can't use the info on SER.net? Crap. Where would I get that info? Thanks ya'lls!
 

·
pwnd
Joined
·
3,455 Posts
Yea its just a little more anoying than a manual. But steps are the same. Thing is there is two connectors on the TB. And my fans kept coming on and retarding the timing. So we had to wait for them to shut off then it would go back to normal and idle would settle down. But its close to the same as the instructions on se-r.net. Just make sure you unplug the right connector. Think eric disconnected the aac harness on mine too. He may know exact steps.
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #7 ·
I tried cleaning my EGR valve but I can't even get the dang thing off! I think I also need a new gasket,but not sure where I can get one of those. Thanks to everyone that replied.
 

·
Registered
Joined
·
705 Posts
<font face="Verdana, Arial" size="2">Originally posted by Bowlcut:
Yea its just a little more anoying than a manual. But steps are the same. Thing is there is two connectors on the TB. And my fans kept coming on and retarding the timing. So we had to wait for them to shut off then it would go back to normal and idle would settle down. But its close to the same as the instructions on se-r.net. Just make sure you unplug the right connector. Think eric disconnected the aac harness on mine too. He may know exact steps.</font>
I always unplug both



------------------
Ryan Walsh, 1997 200sx SE-R w/ ES mounts, JWT s4's, AEBS 4-1, PR CAI, Greddy cat-back, Sportlines/AGX's, Bridgestone re730's, Stillen GTR grill
 
1 - 8 of 8 Posts
Top