SR20 Forum banner
1 - 20 of 39 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Good day folks!

I got a brand new SR16VE with ECU and finished the installation after 3 months of wiring and modification (A/T to M/T). After 1,000 kms mileage (the car is running well), we finally got to test the engine's redline and to our surprise, it registered a disappointing 6,500 rpm at the tach (aftermarket) and Consult-II.

I know we wired this thing properly but what could be the problem? BTW, used a S14-SR20DET MAF because this works best among the following MAFS we tested: S14-SR20DE, U13-SR20DE, U13-SR18DE, A32-VQ20DE, B14-GA16DE. Could this be the source of the problem? Someone said it could be but I doubt because the S14-SR20DET cuts off at 7,400 rpm.

Any ideas guys??? TIA.
 

·
Registered
Joined
·
896 Posts
I think the problem is the maf because SR16 Ecu goes mated to a SR20VE, Xterra Phatfinder maf not SR20DET maf The SR16 maf its 75mm SR20det are smaller so the readings are diferent
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 · (Edited)
@cmng

Engine harness is OEM that came with the SR16VE but the ECU harness is fabricated by us using SR20VE wiring diagram. Sockets and connecters are all genuine coming from various nissan cars (A32, A33, B14, T30, C24, S14). BTW, the original 8-wire VE distributor is used with the engine: did not convert to DE.

@ payu, ryan, digitek

Thanks for the quick replies everyone. Just want to clarify that the engine is SR16VE and the ECU is stock SR16VE ECU (Unisia Jecs). Both brand new.

Regarding the 3.5L pathfinder ECU, I'm not familiar with the specs because our local pathfinder is mated to a 3.2L Diesel engine. Does it come with a VQ35DE engine? I need to know because the only locally available VQ35DE MAF is from the 350Z. We also have a locally available VQ30DE MAF from the A33. Both MAFs we haven't tested yet because only brand new MAFs are available and they're sooooooo expensive. Digitek, thanks for the part number. We looked it up but no luck since the pathfinder gasoline variant is unavailable here. Hope I'll encounter one of these in the scrap yard.
 

·
Premium Member
Joined
·
1,303 Posts
Digitek said:
I agree with the rest it could be the maf.

just for an idea when I installed my VE with VE ECU (JWT) and a DE MAF the car wouldn't go past 4k or something...after installing the ve maf it runs top notch 8k no problem. so try finding a Pathfinder maf 3.5L engine 1999 or so part code: 22680 5J000

3.5L??? I thought this is from the 3.3 ;) .
 

·
Like it or Don't Like it
Joined
·
1,084 Posts
LOL YES its 3.3L my bad I must have overlooked that just typed and posted fast sorry.

here is some other extra usefull info.

Ve maf on 91-94 car needs ve maf pigtail
maxima maf on 91-94 car needs maxima pigtail 92-94
ve maf on 95 up se-r plugs into stock harness
maxima maf on 95 up needs maxima pigtail 95-up
maxima maf 95-98 is for 95 up se-r .
maxima maf 92-94 is for 91-94 se-r.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #11 ·
@Rockwood
LOL ! Beats me! I feel silly calling it MILEage when I speak in KMS.

@Digitek
Got it! 3.3L MAF. Can anyone give me what engine this is from so I can get the matching MAF?

@Payu
Can we share specifications and maybe we can find out what went wrong?


BTW everyone, we made an actual run and the tach limits at 7,200rpm when engaged compared to 6,500rpm when in neutral. Still far from the 8,200rpm we were expecting for a 16VE. :confused:
 

·
Registered
Joined
·
896 Posts
I am going to check for the speed sensor circuit and try to fool the ECU to think there is one conected at least. Because I have no speed sensor and this ECU's use the signal of the speed sensor for the speed governor to cut the fuel at 115mph so if the circuit is open maybe the ECU stays on some kind of safe mode or something I will let you know the results.
 

·
Premium Member
Joined
·
1,303 Posts
Red_Nissan said:
@Rockwood

Got it! 3.3L MAF. Can anyone give me what engine this is from so I can get the matching MAF?

The 3.3L MAF is from the 1996-2003 Nissan Pathfinder with the 3.3 L VG33E engine as well as the 1998 -2004 Nissan Frontier 3.3 L V6 and the Xterra. Good luck.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #14 ·
@Payu
Mine's a bit different. It's not the fuel cut-off that activates at 6,500rpm. It's the rev limiter. Because there is no loss of power or stalling at the limit.

@JRios
Thanks man. The engine code is a big help.
 

·
Premium Member
Joined
·
1,303 Posts
Red_Nissan said:
@Payu
Mine's a bit different. It's not the fuel cut-off that activates at 6,500rpm. It's the rev limiter. Because there is no loss of power or stalling at the limit.
@JRios
Thanks man. The engine code is a big help.

Technically, the fuel cut is the rev limiter. ;)
 

·
Registered
Joined
·
686 Posts
Hey Redd!

that could have been my engine LOL...

didnt u say that the ECU was the 20ve ECU and not the 16ve?? i think its the reason why it revs 6500 at neutral and 7500 at run...

i think theres something wrong on the wiring....coz the 20ve ECU came from the CVT sr20ve...the Ecu should read "drive" to work...any "check engine" lights?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #17 · (Edited)
Hey Alex, is that you? Yeah I heard I just beat you a couple of days for the engine. Hehehehe.

Nope...it's not the ECU. It's an original 16VE ecu. It's the MAF. I just ordered a 16VE MAF. Still waiting for the part to arrive. Will let you know what happens.

BTW, I may have several more VE's coming: some 16's and 20's. I hope an N1 will find it's way. Hehehehe. Interested?

There's also a pulsar GT-R and R32 GTS & GTR on stock. Interested?

Call or text me if you're interested. Might get the skyline GT-S though.

@JRios

Yes they're technically the same in function but works differently. With fuel cut you'll lose power. With electronic limiter you lose the ability to raise your rpm but no loss of power.
 

·
Registered
Joined
·
686 Posts
yup Redd,

ive been here since 2002 and i still aint got a VE LOL :p

good thing you ordered a 16VE maf..hope it works fine..

say waaahhht??? are you getting brand new VE's?? ofcourse im interested hehehe!
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #19 · (Edited)
@B12SR20VE

These aren't brand new units. These are pre-owned. Just text or call you as soon as I receive the manifest.

I'm also waiting for a couple SR20's...a VE and a DET to be installed in B13's.

Leo's car will start phase 2 modification on monday. We're putting in a M/T and cross bars to reinforce the body. He's leaving for Japan on Sunday to buy some parts and arrive just in time for assembly.

Radney damaged his SR20 when his oil filter got loose. He might switch to DET as well but he will sell his old engine. He'll keep the NOS and use it with his DET.
 
1 - 20 of 39 Posts
Top