SR20 Forum banner
1 - 5 of 5 Posts
G

·
Discussion Starter · #1 ·
I have this major problem with my 93 NX 2000. I did my daily maintenance, every 3 mos/3K miles. Well to make things short. My car keeps on stalling on me. I did an ECU test and I got code 55, which means normal. But then the engine lights keeps on showing on my dash. Any suggestion would really be helpful and appreciated. Thanks.
 

·
www.motorists.org
Joined
·
3,047 Posts
Ugh, setting a code then there's no code. Sure you're checking it correctly?

Only other thing I can suggest is to do all the tune up stuff from www.se-r.net like regrounding the MAF, EGR and TB cleaning, plugs, etc.
 

·
Registered
Joined
·
194 Posts
This is just a wild guess, but I heard through my mechanic guy that when our motors are stalling alot, it could be the cams that are flat. He's personally worked on alot of G20's with this problem. Customer comes in and says,"everytime I come to a stop, my car dies", he takes off the valve cover, and presto, flat cams. Maybe this isn't what's causing your problem, but it's another place to check.

Good luck.
 

·
pwnd
Joined
·
3,455 Posts
Most common cause of a stall in a sr20de is MAF needing regrounding. Could be a gooped up TB but doubt it. Cloged fuel filter could be, fouled spark plug or two, timing off just throwing ideas out of my head. With that error light i would first guess the MAF needs to be regrouned. Are you checking the ECU correctly, turn it wait, turn it back i think thats it check se-r.net for propper instructions. I would bet that it is causing the error code that you may not be getting.

i have no cluse what you are talkinga bout nos. flat cams? is that like worn cams? well i doubt it on a sr20 cause the hydrolic lifters would take most of that out of the question. and if it was worn cause of oil starvation other bad things would be happening. like clatter one thing, really loud while running, and down on power. really worn lobes wouldnt do much but sap power and make it run rough as ****. OK heres a IMHO not to be taken personaly (Sounds like the mechanic is trying to find things to charge extra for) I have never heard of such a thing causing a sr20 to die.

check the ground on the MAF as to se-r.net then if that isnt it check your timing, then check other simple things. my money is on that MAF
 

·
Registered
Joined
·
466 Posts
My '96 SE-R had the same problem and a EGR cleaning and a TB cleaning solved it.
 
1 - 5 of 5 Posts
Top