SR20 Forum banner
1 - 8 of 8 Posts

·
Get Some!!
Joined
·
596 Posts
Discussion Starter · #1 ·
I've searched this extensively and there haven't been good responses or answers to this problem:

There's a strange clicking noise coming from my relay/fuse block area. When it clicks, the brake light and battery light flash on and off. Furthermore, my high-beams light stays faintly lit until the high-beams are activated. This all started after my Tsuru install. Also, these lights are not bright at all so something strange is afoot at the local Circle K...

I'm going to check my ground but I need to know if this has happened to anyone else? My alternator is not that old and the relays seem okay.

Also, at one point I got the electrical burning funk from that area.

Thanks,
 

·
Get Some!!
Joined
·
596 Posts
Discussion Starter · #3 ·
Re: Strange electrical clicking from relay area (after Tsuru install - may be unrelated?)

nizzan4u2nv said:
Maybe a bad alternator, try changing out the magic 3 with some fresh 4ga.
What's the "magic 3"? I'm assuming wiring because you mention 4 gauge??
 

·
GT2835R
Joined
·
7,609 Posts
Re: Strange electrical clicking from relay area (after Tsuru install - may be unrelated?)

Postive from batt to alt.
Negative from batt to chassis ground
Chassis ground to block ground.

Its used all the time in car audio for people who cant get enough current, because of oxidized wiring and back ground contacts and such.
 

·
Get Some!!
Joined
·
596 Posts
Discussion Starter · #5 ·
Re: Strange electrical clicking from relay area (after Tsuru install - may be unrelated?)

gotcha -- good advice. I did a battery relocation and I definitely need to check these since those kits want you to ground to something in the rear of the car which is difficult to do well.
 

·
GT2835R
Joined
·
7,609 Posts
Re: Strange electrical clicking from relay area (after Tsuru install - may be unrelated?)

Make sure when you ground to the chassis and you dremel or sand the paint off and get good contact with the metal.
 

·
Get Some!!
Joined
·
596 Posts
Discussion Starter · #7 ·
Re: Strange electrical clicking from relay area (after Tsuru install - may be unrelated?)

I'm going to do this tonight to see if it'll make all this electrical commotion stop.
 

·
Get Some!!
Joined
·
596 Posts
Discussion Starter · #8 ·
Re: Strange electrical clicking from relay area (after Tsuru install - may be unrelated?)

Ok, I checked the Magic 3 this weekend and all look good, solid, secure -- I haven't put the voltmeter to them yet but I undid everything and resecured them. The clicking is still happening and it's driving me insane!
 
1 - 8 of 8 Posts
Top