SR20 Forum banner

1 - 7 of 7 Posts
9

·
Guest
Joined
·
0 Posts
Discussion Starter #1
hey everyone.
I had just got back from work and I turned off my engine, and I heard this strange noise coming from the back of my classic.
It sounds like the fuel pump. The other day it did the same thing but all I was doing was washing it. It was just sitting there!
Does anyone know if Im looking at future probs or what? NO MODS , yet. Just a cone filter.

------------------
"Spidey"
3x ex-Honda owner
 

·
Stuck on an island
Joined
·
1,284 Posts
my nx dose the same thing some times kinda creepy isnt it ? lol i think its just the fule pump doing its own thing but why i dont know ?

------------------

92 NX2000, kyb agx, intrax springs, jwt pop,
3a Racing muffler with bonzi tip,
17 " mille miglia mm 112, Yokoham avid h4
 

·
Registered
Joined
·
705 Posts
<font face="Verdana, Arial" size="2">Originally posted by Storm88000:
I've only heard of it on the 91-94 SR20's. Never heard it on a B14. </font>
Does it on mine too


------------------
Ryan Walsh, 1997 200sx SE-R w/ ES mounts, JWT s4's, AEBS 4-1, PR CAI, Sportlines/AGX's, Bridgestone re730's, Matrix FSTB, Stillen GTR grill
 
9

·
Guest
Joined
·
0 Posts
Discussion Starter #6
well, thank goodness.
Im just kinda paranoid since I yanked out all my emissions crap. Thanks again fellows!!!!
 

·
Registered
Joined
·
189 Posts
<font face="Verdana, Arial" size="2">Originally posted by 94_REDSE-R:
well, thank goodness.
Im just kinda paranoid since I yanked out all my emissions crap. Thanks again fellows!!!!
</font>
how was the performance when you did that?

My car has the hesitation thing right now, so I am contimplating cleaning or just removing my EGR. If you remove it, how do you go about doing so. Thanks, shea
 
1 - 7 of 7 Posts
Top