SR20 Forum banner

1 - 9 of 9 Posts
G

·
Discussion Starter · #1 ·
ok guys another turbo question. I just got done putting a front mount intercooler in my DET. The size is like the Fmax intercooler. Ok here is the problem For some reason the turbo is boosting at 15 psi. Without the HKS EVC EZ on. We didnt do anything else beside the intercooler. Anyone have any ideas???
 
G

·
Discussion Starter · #2 ·
Also we turn the EVC on and tried to turn it down but no luck. Wastegate maybe? How much for another one?
 

·
Enemy of the stupid
Joined
·
4,727 Posts
Check the Vac line from the waste gate. If it's ucked up then it will boost higher....OR maybe you intercooler was leakin boost or your BOV was.....But then again you couldn't turn it down. I say Recheck all your Vac lines.
 

·
Registered
Joined
·
1,166 Posts
does it stay at 15 only? or does it go higher... when that happened to me my vac line from the intercooler was disconnected and tricked the wastegate into staying closed...when that happens the evc cant control it until the line is connected
 

·
Registered
Joined
·
1,166 Posts
do u have a boost gauge? what does it read...how much negative vac do u have when the car is idling? i know for my det its around -19...if urs is around there then it might be ur wastegate cause the vac leaks from the turbo and intercooler always lets me overboost to whatever and urs is set at 15psi.
 

·
Not on fire... yet
Joined
·
591 Posts
Sounds lie the line ging to the waste gate is leaking. The module for the Boost contoller could be creating the leak. To check if its the waste gate just put the original line to the actuator can (use new hose hust to be sure) and give it a try, it shoudl just boost to the factory set limit or so.

------------------
93 NX2K
some stuff and a DET
"project street mod?"
1988 BMW M3 w/ a few toys
 

·
BOOSTIN PROTECH STYLE
Joined
·
1,397 Posts
Also check the hose for holes, I found that my wastegate hose had a hole burnt into it from the wastegate opening up, if thats the problem use some sort of heat resistant material sleeving from summit or somebody.

<font face="Verdana, Arial" size="2">Originally posted by RacerX:
Sounds lie the line ging to the waste gate is leaking. The module for the Boost contoller could be creating the leak. To check if its the waste gate just put the original line to the actuator can (use new hose hust to be sure) and give it a try, it shoudl just boost to the factory set limit or so.

</font>


------------------
Mike.
Turbo Classic, T3/T04e Tial 35mm ".65Bar" Blitz BOV, Custom piping griffen intercooler Core with HK$ EndTanks,custom manifold, 370cc injectors, paxton fpr, Eibach Sportlines, everything else was stolen,:( Pectel coming up bigger Injectors and custom fuel rail. DAMN VILLIANS.
 
G

·
Discussion Starter · #9 ·
I like to thank everyone who replied. The vacum lines were mix up with the BOV. Also There was a hole in the wastegate line. So thank you all.

Richie Soliven Representing Split Second Racing in Va beach,VA
SR20DET Power, HKS EVC EZ( boosting at 10 psi), HKS TURBO TIMER, JWT ECU , Greddy catback exhaust, 3 in ATR Race Cat(That is hollowed out), 3 in downpipe,300zxTT fuel pump HKS plugs,Magnecor wires, SSR rims 18x7.5(TRYING TO GET RID OF),relocated battary to the trunk, AGX'S struts and Ground Controls, Stillen kit
 
1 - 9 of 9 Posts
Top