SR20 Forum banner

1 - 6 of 6 Posts
G

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Today I just got my MSD 550 injectors,Fuel press raiser, Corba MAF, and JWT 3 ECU w/3 bar program.We plug everything up but have problems with the motor. We check all the wires twice. Ok first when I get on boost it not smooth at all. Sec, My oil light comes on only when am at idle. I feel like something is going to blow on my car so am not driving it right now. I already change my oil and made the plug gaps smaller. OHH i ahve the Fuel Press to 40 PSI do I need to go up more? Some help please.

Richie
 

·
Enemy of the stupid
Joined
·
4,727 Posts
is it stumbling when the car tries to idle and have no power?? You might have wired up the Maf wrong my friend. you should set the FPR to what stock is..... anyone else have any change they want to put in.
 
G

·
Guest
Joined
·
0 Posts
Discussion Starter #3
It stumble only when the K&N filter was off the corba maf.At idle the oil light comes on.
What is the stock FPR? Well does anyone have the right wiring for the Corba MAF so I can make sure. When I get some boost its not smooth. Help

Richie
 

·
Registered
Joined
·
616 Posts
Richie, what fuel rail are you running? What FPR are you running?
Do you have a FSM?
Stock fuel pressure is 36psi at idle. My G20 turbo idles at around 40psi.
How do you know that your car runs poorly without the filter on?
When are you going to race Alex the Italian for money?

------------------
Jason Garrett Young
turbo se-r and G20
www.jgycustoms.com
 
1 - 6 of 6 Posts
Top