SR20 Forum banner

1 - 20 of 23 Posts

·
Registered
Joined
·
619 Posts
Discussion Starter #1
My car is leaking Anit-freeze and is making some wierd knocking type noise... anyone have any ideas?? i was thinkin water pump....
 

·
SE-R Mana
Joined
·
759 Posts
I think you'll need to investigate further and tell us where the coolant is leaking and where the knocking is coming from.

I don't recall knocking as being a syptom of a failed water pump so you will have to put your head under the hood and try and pinpoint the problem spot(s).
 

·
Registered
Joined
·
214 Posts
YES SER said:
My car is leaking Anit-freeze and is making some wierd knocking type noise... anyone have any ideas?? i was thinkin water pump....
The bearings on my water pump started to go south a while back, but I decided to replace it when I was dripping coolant in that area. The bearings on it felt horribly gritty and it was the source of my excessive engine "chatter."

Michael.
 

·
Registered
Joined
·
619 Posts
Discussion Starter #4
Well its raining today but tomorrow i will check it out and try to give u a better perspective of whats going on...
 

·
Registered
Joined
·
619 Posts
Discussion Starter #5
Ok i went out n checked it out the knockin type noise is definitly coming from around the water pump or around the pulleys, and the leak is coming from around the same area i can whip the anti freeze under the oil pan on the bottom of the car but i cant see where its coming from...
 

·
Registered
Joined
·
214 Posts
How many miles are on your car? My water pump started "chattering" at around 90k and I replaced it at around 100k (I also replaced the front engine mount).

If your car has high mileage, then my guess would be the water pump. Your symptoms sound familiarly like mine.

Michael.
 

·
Registered
Joined
·
619 Posts
Discussion Starter #8
My car has 107,xxx miles... But the knocking is probly the water pump too or another problem?
 

·
Registered
Joined
·
619 Posts
Discussion Starter #9
Well i changed both my belts and while doing that i noticed there was a screw missing in my altenator wit was the knocking noise... So the knocking is gone but its still leaking anti freeze witch means i still need a water pump....Dont use belt dressing it only messes up ur belts thats my new knowledge for the day...
 

·
oh so LAZY
Joined
·
9,747 Posts
ok, jack up the right side of the car, take off the wheel, remove the splashguard, and start it up to see where the coolant is comming from. if it comes from behind the water pump pully, then the pump is your problem and coolant is flowing out the relief hole.
 

·
Registered
Joined
·
619 Posts
Discussion Starter #14
I did that and thats is exactly where its coming from... but i geuss i have another problem b/c my check engine light is on too....
 

·
Registered
Joined
·
619 Posts
Discussion Starter #17
Alright i got anxious and couldnt wait till tomorrow.. i went out and did it but it didnt blink at all but the CEL went away...maybe the light on my ecu is bad???
 

·
Registered
Joined
·
619 Posts
Discussion Starter #19
yeap, key in the ignition all the way before turned on then turn screw all the way clock wise wait 2 seconds then all the way counter clock wise...i dunno bout the light so since it didnt work i didnt know what to think, but the CEL is out...
 

·
Registered
Joined
·
1,928 Posts
Ok, what you did was reset the ECU's MIL. If it comes back on again, follow the instructions in the link I sent you and see how many flashes you get.
 
1 - 20 of 23 Posts
Top