SR20 Forum banner
1 - 7 of 7 Posts

· Banned
Joined
·
2,786 Posts
tim's 95 se-r said:
its a 95 se-r, when im driving, and let off the gas, kinda coasting in gear, it sounds similar to a bad cv axle click, what could this be? bad mount, bad inner joint?


Its is constant clicking like click, click, click...keeps going? or just kinda like a thump thump and thats it? It could be your CV joints, but my gues is if its more of a kinda thump that your pass side motor mount has gone bad, or maybe a couple of them.
 

· Banned
Joined
·
2,786 Posts
tim's 95 se-r said:
its kind of a thump thump, and then gets quiter.. ill probably replace both. all mounts, and axle. hopefully its one of those.

If its a thump, it is definately your pass side mount. Were you thinking of getting solid mounts or inserts at all? Do you have AIM? If so hit me up @ djmayhem03 and I will help you out more. Otherwise just post back here.
 

· Registered
Joined
·
22 Posts
Discussion Starter · #5 ·
i think i might have figured it out, the rear mount is bad, but it seems like the carrier bearing, that the pass. side axle goes into is bad, i let it run while i was under it, and used a screwdriver as a stethoscope kinda deal, and there was a shitload of noise coming from it. it seems like the noise is getting worse though, so its really stressing me out.

also, it will do it if you coast in neutral, until you hit the brakes.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top