SR20 Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
858 Posts
Discussion Starter #1
I put in some face gauges and now the needles are off . any body put these in please help the rpms ar off and the heat range gauge is off. also the speedometer is stuck on 40 any advise is appreciated! should they be loose?

------------------
91 SE-R,10:1 comp.pistons,balanced &blueprint rebuild.comp.4angle valve job,extrude honed heads/intake manifold,No emissions.crap,RC TB/MAF,nismo cams,UR pulleys,stillen4-1 ceram.header,nismo/centerforce dual fric.clutch,PR CAI,2 1/2 test pipe,mandrel 2 1/4 superturbo ex.,and a whole bunch of other goodies! boost is in the works ,hell yeah 3:16!
 

·
Registered
Joined
·
858 Posts
Discussion Starter #2
the needles were all placed in the right positions and with a full tank of gas so the fuel one coiuld be set at F. but turned the car on and the idle says 1500 when it's really at 750 800 rpms and engine temp stays on the H and isn't over heating.they look so hot but rather have them exact. hello am I the only one with white gauges c'mon fellas?
 

·
pwnd
Joined
·
3,455 Posts
Well if your tach is moving you did that somewhat correct and you didnt break it. The speedo is always finicy according to Eric. What he ended up doing was setting on the dyno, put the dyno at like 30mph hit cruise and put his needle on like that. The Temp gauge sounds like its just in the wrong place. I would either call the manufacture up and see what they say for tips, or just try again.

Atleast you can get white faced guages, I cant. Dont understand why they made a run for the 91-92, 2 years. So why not make another run of 93-94, 2 years. Argghhh

------------------
Thats my opinion and I could be wrong

93 classic
Aztec Red, Automatic, POP, STB, OEC battery tie down, AD22VF's, Pirelli P4000's

 

·
Registered
Joined
·
858 Posts
Discussion Starter #5
I messedup the temp gauge so I ordered a new one 32 bucks. the speedo is working but off.gonna get it recalibrated at a speedo shop. when I drive at ten mph it reads 20 so I 'll probably just subtract depending on how much they want to fix it. according to the gauge , the car is crazy fast!hehe
thanks guys.
 
G

·
I *tried* putting white gauges in my car, but that didnt work. I broke the tach, the the spring for the speedo got stretched out so it would be 20mph+ and would come down slowly. I had to buy new gauges. I learned my lesson.. unfortunetly
 

·
AWD owns me
Joined
·
4,167 Posts
They do make gauge overlays for all classics. It's a place called www.Importperformance.com $25 bucks!!! Got mine and i was impressed. I have blue, so it costed 5 bucks more.
 

·
pwnd
Joined
·
3,455 Posts
The overlays looked like total ass from all the pics I have seen. Execpt the carbon fiber lookalike stuff. Because its already close to black you cant tell the places thaty are missing and the white letters on like white looks like ass. I want real white faced gauges, but did think about the carbon fiber it dont look that bad.
 

·
AWD owns me
Joined
·
4,167 Posts
I just kept in mind that they only costed 30 bucks and there wasn't any other gauges made for a 93, ya know.
 

·
Registered
Joined
·
858 Posts
Discussion Starter #10
ya I have the real white face replace ments. look so hot and then I painted the plastic in front of the gauges aluminum. match with the polished aluminum and real carbon fiber accents in the ride. everyother gauge works except the temp gauge it moves soooo slow. but I guess works. still replacing that one cause it's an important gauge IMHO. after sitting for a while, the ride is back and looks better than ever. plates and all!
 

·
Registered
Joined
·
54 Posts
<font face="Verdana, Arial" size="2">Originally posted by redman007:
the needles were all placed in the right positions and with a full tank of gas so the fuel one coiuld be set at F. but turned the car on and the idle says 1500 when it's really at 750 800 rpms and engine temp stays on the H and isn't over heating.they look so hot but rather have them exact. hello am I the only one with white gauges c'mon fellas?</font>
Love my white faced guages...but I had them professionally installed...I cheated! I had the indicators painted red also, looks so great. Wise thing too is to put all new bulbs in when in there.

Visit my web page to get an idea of what My SE-R is all about. I will say it is not heavily modded. Just well taken care of and babied! Best car I ever owned...

------------------
'91 SE-R, Vail White, 5 speed, LSD, Leather, Roof, Borbet Type H 15"wheels, Z-rated Dunlop SP5000 tires, Blaupunct RDS Nevada 180 watt CD reciever W/4 Blaupunct factory sized speakers, NR Industries White Face guages w/red indicators, body color factory grille. Babied 104K miles. NEVER abused or smoked in.
Web-page http://community-2webtv.net/SentraSE-Rman/My1991ClassicSentra/
 
1 - 11 of 11 Posts
Top