Tmic with no hood scoop - SR20 Forum
 
Thread Tools
post #1 of 2 (permalink) Old 06-22-2019, 05:29 AM Thread Starter
SE-R Newbie
 
Join Date: Apr 2018
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
(Thread Starter)
Tmic with no hood scoop

Alright so this is my first post and I hope I'm posting in the right spot😅. I recently got my 4th B13 SER and I personally believe it's too clean and complete to cut any of it up when I go turbo. So I'm wanting to go with a top mounted intercooler in order to keep a stock look now my main question is has anyone mounted a tmic without cutting up the hood? I've seen a few posts where people says it's perfectly fine with no hood scooped and some saying it's useless unless you get air pushed into it. Also if going fmic is there any way to route it without removing A/C and or cutting of the bumper/other components?
Montezuma is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 07-13-2019, 04:25 PM
Charlie Brown look alike
 
Join Date: Dec 2001
Location: Suffolk, Virginia
Posts: 3,825
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 23 reviews
In short, you can use a TMIC without cutting into the hood. It will be of more use if cooler air can get to it. FMIC = cutting the front bumper out some.

'92 Super Black Se-r w/ just mods - SOLD
'91 Super Black Se-r stock (for now )
"I'm more afraid of being nothing then I am of being hurt."
Peanuthead is offline  
Sponsored Links
Advertisement
 
Reply

  SR20 Forum > Main Forums > Turbo


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome